Google to Drop Support for Older Web Browsers

Jun 6, 2011 6:00 AM PST

SUNNYVALE, Calif. — Google announced that it will be ending support for older browsers.

Starting Aug.1, Google apps will only support the current up-to-date browser. Google Apps will no longer provide support for anything below Firefox 4, Internet Explorer 8 and Safari 4.

This is part of Google’s plan to overhaul its online apps service that will rely on the new HTML5 web standard, which all of the current browsers support.

"For web applications to spring even farther ahead of traditional software, our teams need to make use of new capabilities available in modern browsers," said Venkat Panchapakesan, vice president of Google engineering.

Anyone who uses Chrome, Google's own browser, will not be affected, regardless of which version they're using because Chrome was built with deep HTML5 support from the beginning.

All of the products under Google's Apps brand will be affected including Google Docs, Google Talk, Google Calendar, Gmail and Google Sites.

More Adult Industry News »
About / Contact