Major Vulnerability Hits WordPress

Aug 7, 2014 10:00 AM PST

LOS ANGELES — A vital security warning has been issued to the many users of self-hosted WordPress installations — a user base that includes countless adult websites.

In addition to affecting WordPress users, the exploit, which employs an XML Quadratic Blowup Attack, also affects users of the Drupal platform, which while relatively popular, does not have the vast market share of the Open Source WordPress solution — which may be adult entertainment’s most widely used content management system (CMS) and publishing platform.

As an example of the platform’s overall reach, recent World Wide Web Consortium (WC3) statistics reveal that 23 percent of today’s web is powered by WordPress.

The exploit is capable of immediately crashing a website, by causing complete usage of available CPU power and memory, while also causing a Denial of Service attack on the software’s MySQL database — but fortunately, this attack can be defeated by simply updating the software to its latest version.

The WordPress security team has now released the WordPress 3.9.2 system update and is strongly encouraging users to update their sites immediately. The Drupal security team has likewise issued a fix and also recommends users immediately update to its latest version.

The exploit was discovered by Salesforce.com security expert Nir Goldshlager, who explains that this attack inflates a small XML document of several hundred kilobytes into multiple gigabytes, crushing any Apache server in a matter of moments.

“If an attacker defines the entity ‘&x;’ as 55,000 characters long, and refers to that entity 55,000 times inside the ‘DoS’ element, the parser ends up with an XML Quadratic Blowup attack payload slightly over 200 KB in size that expands to 2.5 GB when parsed,” Goldshlager says. “This expansion is enough to take down the parsing process.”

Goldshlager has released a video demonstrating the attack in action.

More Adult Industry News »
About / Contact